← Back to Patent Explorer
US6370448B1 Expired / Lapsed US ⏱️ 0.0 years remaining

Communication technique for field devices in industrial processes

Assignee: Rosemount Inc
•
Filing: 1998-10-12
•
Granted: 2002-04-09
•
Expires: 2018-10-12
📄 Original PDF 🌐 Google Patents 🔄 Sync Now

Abstract

Abstract A process device is adapted to couple to a process control loop and communicate on the process control loop. Communication on the process control loop is effected in accordance with an internet protocol. A process communication device is also provided which couples to the process control loop, and an internet. The process communication device provides process control information received from the process control loop, to the internet. Conversely, the process communication device also provides information received from the internet to the process control loop.

Inventors

  • 👤 Evren Eryurek

Bibliographic Details

Application Number —
Jurisdiction US
Data Source google_patents
Last Synchronized 2026-10-28 14:25
CPC Classifications
G; G05; G05B; G05B19/00; G05B19/02; G05B19/04; G05B19/042; G05B19/0421; G05B19/418; G05B19/4185; G05B2219/00; G05B2219/20; G05B2219/23; G05B2219/23298; G05B2219/23299; G05B2219/23304; G05B2219/25; G05B2219/25008; G05B2219/25174; G05B2219/25428; G05B2219/30; G05B2219/31; G05B2219/31104; G05B2219/31121; G05B2219/31129; G05B2219/31156; G05B2219/31186; G05B2219/31205; G05B2219/31422; G05B2219/32; G05B2219/32126; G05B2219/34; G05B2219/34038; Y; Y02; Y02P; Y02P90/00; Y02P90/02

Claims Analysis

Total Claims: 19
Claim 1
Independent Claim 154 words
A process device adapted to couple to a fluid process control loop, the process device comprising: a regulator circuit adapted to couple to the process control loop and power the process device with power received from the process control loop; loop interface circuitry adapted to couple to the process control loop to send and receive loop signals to and from the process control loop; processor circuitry operably coupled to the loop interface circuitry, the processor circuitry adapted to receive a sensor output; a memory operably coupled to the processor circuitry, the memory containing an internet address of the process device, the internet address comprising at least four groups of data each group comprising at least eight bits; and wherein the loop interface circuitry is configured to receive data packets from the process control loop which contain the internet address and to transmit data packets on the process control loop which include the internet address.
Claim 2
Dependent Claim 154 words
A process device adapted to couple to a fluid process control loop, the process device comprising: a regulator circuit adapted to couple to the process control loop and power the process device with power received from the process control loop; loop interface circuitry adapted to couple to the process control loop to send and receive loop signals to and from the process control loop; processor circuitry operably coupled to the loop interface circuitry, the processor circuitry adapted to receive a sensor output; a memory operably coupled to the processor circuitry, the memory containing an internet address of the process device, the internet address comprising at least four groups of data each group comprising at least eight bits; and wherein the loop interface circuitry is configured to receive data packets from the process control loop which contain the internet address and to transmit data packets on the process control loop which include the internet address.
Claim 3
Dependent Claim 29 words
The process device of claim 1 wherein the internet address is an Internet Protocol address as defined by RFC 791, promulgated by the Internet Engineering Task Force September, 1981.
Claim 4
Dependent Claim 56 words
A process device adapted to couple to a fluid process control loop, the process device comprising: means for providing power to the process device with power received from the process control loop; means for storing an internet address; and means for sending and receiving data containing the internet address to and from the process control loop.
Claim 5
Dependent Claim 56 words
A process device adapted to couple to a fluid process control loop, the process device comprising: means for providing power to the process device with power received from the process control loop; means for storing an internet address; and means for sending and receiving data containing the internet address to and from the process control loop.
Claim 6
Dependent Claim 101 words
A process device adapted to couple to a fluid process control loop, the process device comprising: loop interface circuitry adapted to couple to the process control loop to send and receive loop signals to and from the process control loop; processor circuitry operably coupled to the loop interface circuitry, the processor circuitry adapted to receive a sensor output and format the sensor output in accordance with an internet protocol as defined by RFC 791, promulgated by the Internet Engineering Task Force, September, 1981 and provide the formatted sensor output to the loop interface circuitry for transmission on the process control loop.
Claim 7
Dependent Claim 101 words
A process device adapted to couple to a fluid process control loop, the process device comprising: loop interface circuitry adapted to couple to the process control loop to send and receive loop signals to and from the process control loop; processor circuitry operably coupled to the loop interface circuitry, the processor circuitry adapted to receive a sensor output and format the sensor output in accordance with an internet protocol as defined by RFC 791, promulgated by the Internet Engineering Task Force, September, 1981 and provide the formatted sensor output to the loop interface circuitry for transmission on the process control loop.
Claim 8
Dependent Claim 33 words
The process device of claim 4 and further comprising a regulator circuit adapted to couple to the process control loop and power the process device with power received from the process control loop.
Claim 9
Dependent Claim 17 words
The process device of claim 4 wherein the process control loop is a two-wire process control loop.
Claim 10
Dependent Claim 224 words
A process device adapted to couple to a fluid process control loop, the process device comprising: a regulator circuit adapted to couple to the process control loop and power the process device with power received from the process control loop; loop interface circuitry adapted to couple to the process control loop to generate process control loop signals in accordance with a process control loop protocol in response to reception of output packets, and selectively provide input packets based upon received process control loop signals; internet protocol circuitry operably coupled to the loop interface circuitry and adapted to provide the output packets to the loop interface circuitry in accordance with an internet protocol and based upon output segments received by the internet protocol circuitry, each output packet comprising an output segment, a source internet address, a destination internet address, and data indicative of a transport type, the internet protocol circuitry further adapted to receive the input packets from the loop interface circuitry; transmission circuitry operably coupled to the internet protocol circuitry and adapted to transform output data received by the transmission circuitry into the output segments, and assemble input segments received from the internet protocol circuitry into input data; and processor circuitry adapted to receive a sensor output, and provide the output data to the transmission circuitry and receive input data from the transmission circuitry.
Claim 11
Dependent Claim 224 words
A process device adapted to couple to a fluid process control loop, the process device comprising: a regulator circuit adapted to couple to the process control loop and power the process device with power received from the process control loop; loop interface circuitry adapted to couple to the process control loop to generate process control loop signals in accordance with a process control loop protocol in response to reception of output packets, and selectively provide input packets based upon received process control loop signals; internet protocol circuitry operably coupled to the loop interface circuitry and adapted to provide the output packets to the loop interface circuitry in accordance with an internet protocol and based upon output segments received by the internet protocol circuitry, each output packet comprising an output segment, a source internet address, a destination internet address, and data indicative of a transport type, the internet protocol circuitry further adapted to receive the input packets from the loop interface circuitry; transmission circuitry operably coupled to the internet protocol circuitry and adapted to transform output data received by the transmission circuitry into the output segments, and assemble input segments received from the internet protocol circuitry into input data; and processor circuitry adapted to receive a sensor output, and provide the output data to the transmission circuitry and receive input data from the transmission circuitry.
Claim 12
Dependent Claim 30 words
The process device of claim 7 wherein the transmission circuitry transforms data in accordance with Transmission Control Protocol as defined by RFC 793, promulgated by the Internet Engineering Task Force.
Claim 13
Dependent Claim 30 words
The process device of claim 7 wherein the transmission circuitry transforms data in accordance with User Datagram Protocol as defined by RFC 768, promulgated by the Internet Engineering Task Force.
Claim 14
Dependent Claim 30 words
A data structure embodied in a fluid process device, the data structure comprising: a data field; a transmission control header; an internet protocol header; and a process control loop header.
Claim 15
Dependent Claim 30 words
A data structure embodied in a fluid process device, the data structure comprising: a data field; a transmission control header; an internet protocol header; and a process control loop header.
Claim 16
Dependent Claim 172 words
A process device adapted to couple to a fluid process control loop, the process device comprising: a regulator circuit adapted to couple to the process control loop and power the process device with power received from the process control loop; loop interface circuitry adapted to couple to the process control loop to send and receive loop signals to and from the process control loop; processor circuitry operably coupled to the loop interface circuitry, the processor circuitry adapted to receive a sensor output; and a memory coupled to the processor circuitry and adapted to store instructions for execution upon the processor circuitry, the instructions comprising: an internet formatting routine for formatting the sensor output in accordance with an internet protocol to provide an internet-formatted output; a loop formatting routine for further formatting the internet-formatted output for transmission on the process control loop to provide a loop-forward output; an output routine to cause the processor circuitry to provide the loop formatted output to the loop interface circuitry for transmission on the process control loop.
Claim 17
Dependent Claim 172 words
A process device adapted to couple to a fluid process control loop, the process device comprising: a regulator circuit adapted to couple to the process control loop and power the process device with power received from the process control loop; loop interface circuitry adapted to couple to the process control loop to send and receive loop signals to and from the process control loop; processor circuitry operably coupled to the loop interface circuitry, the processor circuitry adapted to receive a sensor output; and a memory coupled to the processor circuitry and adapted to store instructions for execution upon the processor circuitry, the instructions comprising: an internet formatting routine for formatting the sensor output in accordance with an internet protocol to provide an internet-formatted output; a loop formatting routine for further formatting the internet-formatted output for transmission on the process control loop to provide a loop-forward output; an output routine to cause the processor circuitry to provide the loop formatted output to the loop interface circuitry for transmission on the process control loop.
Claim 18
Dependent Claim 124 words
A process communication device adapted to couple to a fluid process control loop, the device comprising: a memory adapted to contain data indicative of a loop address of the device, and an internet address of the device; loop communication circuitry, coupled to the memory, and adapted to communicate on the process control loop; internet communication circuitry coupled to the loop communication circuitry and the memory, and adapted to couple to an internet to communicate on the internet; and wherein the internet communication circuitry passes information received from the internet to the loop communication circuitry for transmission upon the process control loop, and the loop communication circuitry passes information received from the process control loop to the internet communication circuitry for transmission upon the internet.
Claim 19
Dependent Claim 124 words
A process communication device adapted to couple to a fluid process control loop, the device comprising: a memory adapted to contain data indicative of a loop address of the device, and an internet address of the device; loop communication circuitry, coupled to the memory, and adapted to communicate on the process control loop; internet communication circuitry coupled to the loop communication circuitry and the memory, and adapted to couple to an internet to communicate on the internet; and wherein the internet communication circuitry passes information received from the internet to the loop communication circuitry for transmission upon the process control loop, and the loop communication circuitry passes information received from the process control loop to the internet communication circuitry for transmission upon the internet.

References Cited (Backward Citations)

GB928704A Cited
US3096434A Cited
US3404264A Cited
US3468164A Cited
US3590370A Cited
US3701280A Cited
US3691842A Cited
US3688190A Cited
USRE29383E Cited
US3973184A Cited
FR2302514B1 Cited
GB1534280A Cited
FR2334827B1 Cited
US4058975A Cited
US4099413A Cited
US4102199A Cited
US4122719A Cited
US4250490A Cited
US4337516A Cited
DE3213866A1 Cited
US4399824A Cited
US4571689A Cited
EP0122622B1 Cited
US4635214A Cited
US4530234A Cited
US4707796A Cited
US4649515A Cited
US4517468A Cited
US4644479A Cited
US4642782A Cited
US4777585A Cited
US5303181A Cited
DE3540204C1 Cited
EP0413814B1 Cited
US4736367A Cited
US5005142A Cited
US4992965A Cited
US5122794A Cited
US4873655A Cited
US4907167A Cited
US4831564A Cited
US5274572A Cited
US5193143A Cited
US5488697A Cited
US4841286A Cited
US4924418A Cited
US5043862A Cited
US4964125A Cited
US5197328A Cited
US5099436A Cited
US5067099A Cited
US5148378A Cited
US5103409A Cited
US5098197A Cited
US5081598A Cited
US4939753A Cited
DE4008560C2 Cited
US5333240A Cited
US4988990A Cited
US5089984A Cited
US4934196A Cited
US5469156A Cited
US5269311A Cited
US5293585A Cited
JP2712625B2 Cited
US5305230A Cited
US5265222A Cited
US5311421A Cited
US5111531A Cited
JP2712701B2 Cited
US5235527A Cited
US5134574A Cited
US5122976A Cited
US5053815A Cited
US5430642A Cited
US5142612A Cited
US5408586A Cited
US5121467A Cited
US5167009A Cited
US5212765A Cited
US5224203A Cited
US5197114A Cited
US5282261A Cited
US5175678A Cited
US5130936A Cited
US5924086A Cited
US5367612A Cited
EP0487419A3 Cited
US5265031A Cited
US5214582C1 Cited
US5214582A Cited
US5143452A Cited
US5394543A Cited
US5137370A Cited
US5357449A Cited
US5675724A Cited
US5671335A Cited
US5317520A Cited
US5414645A Cited
US5327357A Cited

USPTO Annuity & Maintenance Windows

Annuity Stage Window Opens Payment Deadline Surcharge Period Until Estimated Fee Status
3.5 Years (Year 4) 2005-04-08 2005-10-08 2006-04-09 $2000.00 Window Closed / Lapsed
7.5 Years (Year 8) 2009-04-08 2009-10-08 2010-04-09 $3760.00 Window Closed / Lapsed
11.5 Years (Year 12) 2013-04-08 2013-10-08 2014-04-09 $7700.00 Window Closed / Lapsed

Assigned Categories & Tags

No categories assigned to this patent yet.

Assign Category Tag