← Back to Patent Explorer
US6085243A Expired / Lapsed US ⏱️ 0.0 years remaining

Distributed remote management (dRMON) for networks

Assignee: HP Inc
•
Filing: 1996-12-13
•
Granted: 2000-07-04
•
Expires: 2016-12-13
📄 Original PDF 🌐 Google Patents 🔄 Sync Now

Abstract

Abstract A method and apparatus for the distributed monitoring of network traffic deploys end system agents to collect traffic statistics at distributed points in the network. These statistics are forwarded to collectors which compile the statistics to create higher level pictures of network performance. A collector may act as a proxy for a prior art standalone network probe and may interact with network management software as though it were a standalone network probe. The invention is designed to work in accordance with a variety of standard network management protocols including SNMP, RMON, and RMON2 but is not limited to those environments.

Inventors

  • 👤 Rick Fletcher
  • 👤 Prakash C. Banthia

Bibliographic Details

Application Number —
Jurisdiction US
Data Source google_patents
Last Synchronized 2026-10-31 16:27
CPC Classifications
G; G06; G06F; G06F8/00; G06F8/60; G06F8/65; H; H04; H04L; H04L41/00; H04L41/02; H04L41/0213; H04L41/04; H04L41/042; H04L41/044; H04L41/046; H04L41/14; H04L41/142; H04L41/50; H04L41/5003; H04L41/5009; H04L41/508; H04L41/509; H04L43/00; H04L43/10; H04L43/12; H04L67/00; H04L67/01; H04L67/02; H04L67/025; H04L67/10; H04L9/00; H04L9/40; H04L12/00; H04L12/54; H04L12/56; H04L12/5601; H04L2012/5625; H04L2012/5626; H04L41/28; H04L43/106; H04L67/34; H04L69/00; H04L69/30; H04L69/32; H04L69/322; H04L69/329; H04W; H04W24/00; H04W24/08

Claims Analysis

Total Claims: 7
Claim 1
Independent Claim 187 words
A method for the distributed collecting of network data traffic statistics, wherein said network comprises end systems (ES) connected to network segments, the method comprising: capturing network data at a plurality of said ESs, said network data observed at said ESs; computing individual network traffic statistics at said plurality of said ESs, said individual traffic statistics being extracted from analysis of said captured network data; including, in each of the ESs participating in said distributed collecting, an agent, said agent being an executable module invisible to a user for collecting traffic statistics and said agent capturing only network data that its native ES sends or receives; transmitting data containing said individual traffic statistics to a collector from said plurality of said ESs; compiling said individual traffic statistics from individual ESs into group network statistics; providing reports based on said compiled statistics, from said collector, to a network manager; transmitting data containing compiled statistics from said collector to a domain collector; compiling statistics from a plurality of collectors at said domain collector; and providing reports based on said compiled statistics, from said domain collector, to a network manager.
Claim 2
Independent Claim 187 words
A method for the distributed collecting of network data traffic statistics, wherein said network comprises end systems (ES) connected to network segments, the method comprising: capturing network data at a plurality of said ESs, said network data observed at said ESs; computing individual network traffic statistics at said plurality of said ESs, said individual traffic statistics being extracted from analysis of said captured network data; including, in each of the ESs participating in said distributed collecting, an agent, said agent being an executable module invisible to a user for collecting traffic statistics and said agent capturing only network data that its native ES sends or receives; transmitting data containing said individual traffic statistics to a collector from said plurality of said ESs; compiling said individual traffic statistics from individual ESs into group network statistics; providing reports based on said compiled statistics, from said collector, to a network manager; transmitting data containing compiled statistics from said collector to a domain collector; compiling statistics from a plurality of collectors at said domain collector; and providing reports based on said compiled statistics, from said domain collector, to a network manager.
Claim 3
Dependent Claim 24 words
The method according to claim 1 wherein said statistics collected are as defined in a standard defined for the gathering of network-wide performance statistics.
Claim 4
Dependent Claim 20 words
The method according to claim 2 wherein said statistics collected are as defined by an RMON or RMON2 monitoring protocol.
Claim 5
Dependent Claim 31 words
The method according to claim 3 wherein said statistics collected are as defined by an RMON or RMON2 monitoring protocol as published in IETF RFC documents, RFC-1271, RFC-1513, RFC-1757 and revisions.
Claim 6
Dependent Claim 40 words
The method according to claim 1 wherein said collector simulates the behavior of a standalone probe such that said manager interacts with and configures said collector as though said collector was a standalone probe and said collector configures said ESs.
Claim 7
Dependent Claim 17 words
The method according to claim 1 wherein a plurality of said ESs communicate using an ethernet protocol.

References Cited (Backward Citations)

US5752003A Cited
US5764912A Cited
US5710885A Cited

USPTO Annuity & Maintenance Windows

Annuity Stage Window Opens Payment Deadline Surcharge Period Until Estimated Fee Status
3.5 Years (Year 4) 2003-07-04 2004-01-03 2004-07-04 $2000.00 Window Closed / Lapsed
7.5 Years (Year 8) 2007-07-04 2008-01-03 2008-07-04 $3760.00 Window Closed / Lapsed
11.5 Years (Year 12) 2011-07-04 2012-01-03 2012-07-04 $7700.00 Window Closed / Lapsed

Assigned Categories & Tags

No categories assigned to this patent yet.

Assign Category Tag